Enable-ComputerRestore not works

rated by 0 users
This post has 2 Replies | 1 Follower

Top 75 Contributor
Posts 45
balubeto Posted: 04-23-2012 12:54 PM

HI

Wanting to enable the local partition to restore system of Windows 7 SP1, I wrote:

PS C:\Windows\system32> Enable-ComputerRestore -Drive "F:\"

but I get:

Enable-ComputerRestore : Include the system drive in the drives list.
In riga:1 car:23
+ Enable-ComputerRestore <<<<  -Drive "F:\"
    + CategoryInfo          : InvalidArgument: (:) [Enable-ComputerRestore], A
   rgumentException
    + FullyQualifiedErrorId : EnableComputerNoSystemDrive,Microsoft.PowerShell
   .Commands.EnableComputerRestoreCommand

 

Why? So, how can I fix this?

THANKS

BYE

Top 100 Contributor
Posts 32

Can you check and make sure your drive is being listed in get-psdrive?

Top 75 Contributor
Posts 45

Since the Enable-ComputerRestore -Drive "F:\" command wants the Administrator rights, in interactive Windows Powershell started from Command Prompt, how do I do this?

THANKS

BYE

Page 1 of 1 (3 items) | RSS
Copyright 2012 PowerShell.com. All rights reserved.